Welcome to Zclub - Australia's Largest Nissan 370Z and Nissan 350Z Forum
Register for FREE to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing topics, give reputation to other members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.


Sign in to follow this  
Followers 0

AC Temperature no range. Only cold or hot

5 posts in this topic

Posted · Report post

HI guys,
I have a 2004 350Z softtop and have had issues with AC unit since I got it. 
The AC unit has 2 options - Cold (when set at 18 on the dial) and Hot when set to anything but 18. Makes no difference is AC button is on or off. There is no range. I have read it can be because of the sun sensor on the dash (no idea how that could be of any effect). I replaced the passenger side one but makes no difference - no surprise there. I have pulled the white AC control box out from under the stereo but everything looks fine. No broken cables, all lights and functions of the unit work - just the ability to adjust them temperature is stuffed. Anyone come across this issue before and been able to find a solution? Really annoying having either a hot or cold cabin and nothing in between!

Thanks!

Tim

Share this post


Link to post
Share on other sites


Posted · Report post

I have the same issue, it's supposedly a fault within the control box. I haven't bothered fixing it but it is annoying.

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for the reply Rob, Hoping I can find someone who has opened up these control boxes but doesn't seem like its that common of a problem. Shall keep hunting before take into a specialist.
Got this reply else where: Not sure if it is right but will look into and write back on here with results.
I really hope its the control box and not the following!

If you're not getting an inbetween range, it could have something to do with the blower box vent valve. That vent valve opens and closes redirecting airflow between recirculate and outside air. If you're getting steady hot or cold when set to both extremes (max cold and max hot) then it sounds like both, your AC Evap core and Heater core are functioning as intended. This is where I would look next. Maybe the servo arm stopped working or broke somehow? It's fairly easy to access the blower motor housing. But before dropping it, I would suggest pulling up the battery cowling under the hood. From there you can visually inspect the vent flap/valve from the outside air inlet port. Make sure it's opening and closing in accordance with your AC controls. I'm not an expert with the Z's AC system beyond this. There could be other components behind the dash that work to together with the blower box to help manage temperature. I believe there are other vent valves/doors that redirect airflow. For example the front window defrost and foot well vent settings.

Share this post


Link to post
Share on other sites

Posted · Report post

Not a bad way to start Rob. Might hunt around some wreckers and see what I can find. Will keep you posted. The thought of having a nice 22 degrees coming out my vents...  A man can dream..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0





  • Topics

  • Posts

    • Invidia HFC
      By harry.egan · Posted
      Where in sydney mate. If possible i might make the journey Sent from my SM-G930F using Tapatalk
    • Invidia HFC
      By ChocSoldier · Posted
      I'm in Sydney unfortunately, was about to suggest that though as we're planning a meet this Sunday.

      I'll see what I can do, but like I said, bit hard to find somewhere where you can do it without drawing attention etc
    • P0011 Code (2012 370Z)
      By Trent Bray · Posted
      Anybody have experience with the error code P0011? car is currently with the mechanic...unable to find an actual issue everything is checking out and few things been checked/ replaced but car is still not running right. Initial easier fixes through troubleshooting or stripping it down to access the gasket behind (unsure if it was the galley gasket) are yet to get it going, timing, valves, actuators etc. seem fine as checked once pulled apart a bit... mechanic said he had one or two more things to try then may have to get it to Nissan dealer. Could it be a simpler fix they have overlooked like oil pressure/ filter? but assuming they had already gone their through process of elimination..
    • 370z soft top replacement
      By Cam · Posted
      Hi guys. I bought a 370 roadster recently and when i was checking it out i noticed a little tear starting. i didnt think much of it because my 350 soft top replacement was pretty straight forward, there was plenty of DIY literature and the tops were all over ebay. Now i own the thing, i went looking to buy a replacement top and....err....no literature and next to nothing available. crap. Help? Suggestions? Cheers!
    • Invidia HFC
      By harry.egan · Posted
      Video would be great if you get the chance. If you are ever in the Newcastle area and have a few minutes let me know as i would like to hear it in person. Sent from my SM-G930F using Tapatalk