Welcome to Zclub - Australia's Largest Nissan 370Z and Nissan 350Z Forum
Register for FREE to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing topics, give reputation to other members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.


Tell me what's wrong with your 370Z.. Cause I'm gonna tell you what's wrong with mine..

58 posts in this topic

Posted · Report post

Starting to find faults with my Z.

- double sided tape showing where my mud guards are.

- double sided tape show where my spoiler sits on the boot (near the rear centre brake light).

- last light on fuel gauge plays up. Missing when full then pops back on after about 100km. Started about the same time as it did on my '09 370z - at 7000km.

- crunches into third at times. Yes my clutch is to the floor. Happens not only when i drive it hard but even when changing gears at under 3000rpm. Happened today when I was changing up at 40kmph thru a side street.

- something is loose and making an annoying faint vibrating sound when I push it past 5000rpm.

Anyone else experiencing these things or have any feedback?

Share this post


Link to post
Share on other sites


Posted · Report post

Sticky hatch :growl:

Share this post


Link to post
Share on other sites

Posted · Report post

Sticky hatch :growl:

Ouch!

I didn't know this was also in the 2010 models.. :(

Share this post


Link to post
Share on other sites

Posted · Report post

Shit, and I just ordered mine

You know my CX9 has never had anything go wrong in 2 years, if the 370 wasn't so sexy I may have bought the RX8 instead just for quality reasons

Share this post


Link to post
Share on other sites

Posted · Report post

Sorry to hear that ronnie

Well I tend to ignore any faults on my 370z for now as i have decided this will be my last nissan as i found nissan customer service is terrible, both with the dealer and Nissan Aust.

Bought a new family car recently and it is the new CX9 and their service was so much better. The last one was the Murano, was thinking of upgrade to the new Murano but due to unpleasant experience, decided not to.

anyway sorry for missing the last meeting. Been sick and having some issues at home.

Share this post


Link to post
Share on other sites

Posted · Report post

Sorry to hear that ronnie

Well I tend to ignore any faults on my 370z for now as i have decided this will be my last nissan as i found nissan customer service is terrible, both with the dealer and Nissan Aust.

Bought a new family car recently and it is the new CX9 and their service was so much better. The last one was the Murano, was thinking of upgrade to the new Murano but due to unpleasant experience, decided not to.

anyway sorry for missing the last meeting. Been sick and having some issues at home.

All good buddy. I hope all issues will be resolved.

You should service with Dandening Nissan as they are great! Just tell em I sent ya.

Happy birthday to mate! :)

Share this post


Link to post
Share on other sites

Posted · Report post

Starting to find faults with my Z.

- crunches into third at times. Yes my clutch is to the floor. Happens not only when i drive it hard but even when changing gears at under 3000rpm. Happened today when I was changing up at 40kmph thru a side street.

Adjust the clutch pedal and see if that fixes it.

Share this post


Link to post
Share on other sites

Posted · Report post

Stuck hatch which has had the uprated springs installed once already.

The last two lights on the fuel gauge do not light up when full.

Diff/wheel bearing whine between 55-60kms in fifth.

Top end engine noise on tick-over.

Wiper blades are no longer soft, because they judder when used.

Clutch pedal has a high release which Nissan refused to adjust on 10,000kms service.

It has been booked in for 20,000kms service this Tuesday where I will try and get the above addressed, but I do not hold out much hope as I am fully aware how main dealers and warrantee issues work.

Share this post


Link to post
Share on other sites

Posted · Report post

yo ronnie, maybe the crunch coz you suck at manual? jk jk hehe..........the double sided tape is wierd, no issue with mine yet, altho when they did put them on, they told me not to wash it a few days or so, so it can set. Did you leave yours? fuel light, i still have issue with the last one.

Share this post


Link to post
Share on other sites

Posted · Report post

I'll probably only have the Z for another 18 months or so then change over...I love the Z, but I think it's just a "phase" thing....hmm....I might cross back over to the Germans and buy a new BMW M3, a hell of a lot more money but the quality, engineering, comfort, performance is just worlds apart.

Share this post


Link to post
Share on other sites

Posted · Report post

Ronnie, when changing gears you still need to push the clutch in going to third.... or is it your seating position again? :P

If it is grinding in third then take it to nissan. I haven't had any grind whatsoever.

Only problems I have are the same as almost everyone else... Last LED on the fuel tank and the hatch springs.

Share this post


Link to post
Share on other sites

Posted · Report post

Nothing wrong with mine .... yes, the hatch rattles a little on really rough roads, and I had to fit an engine oil cooler and a finned diff cover, and I have replaced the brake rotors with higher quality slotted rotors, and I am fabrricating some brake ducts, and I am about to replace the diff 'coz I have killed the OEM viscous LSD, but, for $65K I have a car I can drive to work, get ~10 litres/100K's, and also lap Sandown in 1:30, PI in ~2:00minutes, Winton in 1:42, and now Mallala in 1:24 - this is one sweet handling car and they are realtively quick.

I still reckon this is quicker than a BM 135i and $20K cheaper and a "heap" cheaper to service ...

Sure I can't keep up with an EVO/STi running 22psi (for that, I have my MG).

I haven't had any dealer/service issues and I have just clicked over 30K klicks ..... its a great bus !!!

RB

Share this post


Link to post
Share on other sites

Posted · Report post

Nothing wrong with mine .... yes, the hatch rattles a little on really rough roads, and I had to fit an engine oil cooler and a finned diff cover, and I have replaced the brake rotors with higher quality slotted rotors, and I am fabrricating some brake ducts, and I am about to replace the diff 'coz I have killed the OEM viscous LSD, but, for $65K I have a car I can drive to work, get ~10 litres/100K's, and also lap Sandown in 1:30, PI in ~2:00minutes, Winton in 1:42, and now Mallala in 1:24 - this is one sweet handling car and they are realtively quick.

I still reckon this is quicker than a BM 135i and $20K cheaper and a "heap" cheaper to service ...

Sure I can't keep up with an EVO/STi running 22psi (for that, I have my MG).

I haven't had any dealer/service issues and I have just clicked over 30K klicks ..... its a great bus !!!

RB

THAT's the spirit!!!

From reading this thread I was begining to wonder how many of the guys on this forum drive something llike a Rolly Royce or a Bently as thier family car :P

Share this post


Link to post
Share on other sites

Posted · Report post

Starting to find faults with my Z.

- double sided tape showing where my mud guards are.

- double sided tape show where my spoiler sits on the boot (near the rear centre brake light).

- last light on fuel gauge plays up. Missing when full then pops back on after about 100km. Started about the same time as it did on my '09 370z - at 7000km.

- crunches into third at times. Yes my clutch is to the floor. Happens not only when i drive it hard but even when changing gears at under 3000rpm. Happened today when I was changing up at 40kmph thru a side street.

- something is loose and making an annoying faint vibrating sound when I push it past 5000rpm.

Anyone else experiencing these things or have any feedback?

I have the fuel light issue plus crunchy gears (mainly into 2nd & 3rd) but it gets better when its warm - I will change to redline synth gear oil soon and Im sure it will be much better.

What concerns me the most is I also have a vibrating noise at 5000rpm coming from under the gear lever. It starts at about 4500 and goes away about 6000 - its at its worst at ~5000 and is most noticable in thrid... Anyway what I found is that if you hold the gear lever and pull to either side it goes away. is this the same as yours (or anyone elses?). I am booked in to have it looked at in a couple of weeks...

Share this post


Link to post
Share on other sites

Posted · Report post

I have the fuel light, buzzing and hatch release issue...

I love and hate this car...

Share this post


Link to post
Share on other sites

Posted · Report post

This will be my first and last Nissan.

I'll prob go for a HSV or FPV next time around due to the aftermarket support on the table.

Or pay a little extra and go german.

Share this post


Link to post
Share on other sites

Posted · Report post

My car is fine.....with the only problem the fuel LED's which isn't a big deal for me.

The hatch was an issue, but I got the longer springs and then put 2 x 10c pieces in each when that didn't solve it. It's perfect now and pops every time.

My clutch engages a bit higher now, but I think that is just an adjustment issue as things wear which I'll get done. Gears are fine, smooth into 3rd every time although a get a lot of clutch rattle which is "normal". I will be filling it with Redline pretty soon though.

My car will be end of contract in July 2012, so I'll sell it then and get something else. I love Nissan's so I wouldn't rule out another Z if it was factory turbo, otherwise no.

Share this post


Link to post
Share on other sites

Posted · Report post

I just hate Nissan for not getting it right, 15 years ago this sorta stuff wouldn't happen in a Japanese product... They had anal levels of detail but now it's slipping...

Share this post


Link to post
Share on other sites

Posted · Report post

hatch release is ineffective in my 2010 roadster.also have lag on accelaration and gear searching at times from auto.

nothing too bad ,just annoying.

my previous 2005 350z auto did not have these issues ,and while the new car is more sophisticated ( read soft for the american market),the 350z had

instant raw power ,brilliant shifts and great engine sound in cabin.

overall slightly dissapointed.

Share this post


Link to post
Share on other sites

Posted · Report post

hatch release is ineffective in my 2010 roadster.also have lag on accelaration and gear searching at times from auto.

nothing too bad ,just annoying.

my previous 2005 350z auto did not have these issues ,and while the new car is more sophisticated ( read soft for the american market),the 350z had

instant raw power ,brilliant shifts and great engine sound in cabin.

overall slightly dissapointed.

JChrist... the hatch doesn't work properly for the roadster too... Nissan... Come on now... How retarded can you get?

Share this post


Link to post
Share on other sites

Posted · Report post

I notice the lag as well compared to my old 350 but it's getting better with more k's. This car needs to be reved more as torque comes in later I think...

Share this post


Link to post
Share on other sites

Posted · Report post

Here is my list:

Hatch doesn't release - fixed under warranty, still doesn't always release.

Missing fuel lights - again fixed under warranty (replaced the sender in the tank with an apparently "upgraded" unit). Two weeks later lights were missing again.

And the big one:

Couple of weeks ago was driving, put the clutch in to change gear and the pedal stayed flat on the floor. In the fern of all places, awesome... Two hours later the car was towed by Nissan, put in a holding yard (as it was on a weekend) and then repaired. Clutch was bled and fluid replaced. Seems to be ok since but it's one of those lurking worries it will happen again.

Share this post


Link to post
Share on other sites

Posted · Report post

5,000 klms and only one bad issue being " Can't find a clear raod with no cops to open it up :roadrage: "

Pleased to report not one issue with the car

Cheers

Pete

Share this post


Link to post
Share on other sites

Posted · Report post

Can someone please describe to me what the 'Hatch release' problem is?

Share this post


Link to post
Share on other sites

Posted · Report post

Can someone please describe to me what the 'Hatch release' problem is?

on my 370z roadster when you push the button to release the hatch/boot it does not release the boot with sufficient power to push it up.

this means i need to manually lift boot and as there is no recess or latch to assist i have already noticed scuff marks or small scratches around the centre of the boot lip.

i am not sure if this is the same as for others in the club ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now