Welcome to Zclub - Australia's Largest Nissan 370Z and Nissan 350Z Forum
Register for FREE to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing topics, give reputation to other members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.


VQ35HR twin throttle issue

4 posts in this topic

Posted · Report post

Hi all,

Recently we did the throttle body mod by blocking off the water supply to them. 

 

While there my mate decided to clean the insides of the tb with t.v. cleaner. 

 

Long story short  it does this weird thing when coming off throttle just under 2000rpm it hangs then comes down. 

 

I've removed battery let it drain of power overnight did the idle re learn etc. Doesn't seem to effect it still the same.

 

Is there any other way to do this.  When my friend cleaned the tb battery was still connected. 

I been reading this not a good idea. 

 

Any help is appreciated

 

 

 

 

Share this post


Link to post
Share on other sites


Posted · Report post

Ever since I bought it the Speedo also does this when reds are on. 

The needles for both Speedo and tacho jump up.  Any ideas on this also?

 

Share this post


Link to post
Share on other sites

Posted · Report post

No one have this issue?

Share this post


Link to post
Share on other sites

Posted · Report post

Long story short  it does this weird thing when coming off throttle just under 2000rpm it hangs then comes down. 

It does that on the 370.

I think it's the ECU controlling the throttle for emissions purposes.

Not sure if that applies to the 350 though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now





  • Topics

  • Posts

    • Custom y-pipe and cat combination, I need help!
      By richiez · Posted
      Hey guys I need some help. I bought this car second hand, it has some work done to it but I'm unsure on the details. I'm trying to get a CBE for my car so I thought I'd look underneath. I know part of the exhaust have been replaced since it got sold to the dealership. It looks like the ypipe and cat are a one piece set up? And looks nothing like the stock stuff. What is this pipe? Is it custom? I'm guessing I can only buy a y-back exhaust at this stage unless I buy a CBE and a cat. Thanks!http://cloud.tapatalk.com/s/5cb9a7deea9ce/YouCut_20190419_204915267.mp4 Sent from my Pixel 3 XL using Tapatalk
    • 2009 - 2010 v20 MAPS
      By 370Cal · Posted
      Do you have any copies left portes? Sent from my iPhone using Tapatalk
    • 07 Z with mystery illness
      By Muzzytt · Posted
      Hey mate I recently had a similar issue.  I ended up getting the NDS III app on my phone and did the idle 're learn but mine was not as bad as what you're describing.  I pulled an injector to try it to 're learn etc but idled around 700 rpm.
    • Write off advice
      By S3RG388 · Posted
      Hi All, I am new to the forums so it is very nice to meet you all and apologies if I am posting in the wrong section. Recently my 370z (2010 convertible auto) has been hit in the back and after a month of assessments and deliberations the insurance company decided it will be a write off due to high costs of repair needed for a full chassis rebuild in the rear. Now they have given me two options: 1 - Take the market value of 23k minus 1.6k of outstanding insurance payments for the period. So about 21.4k. 2 - Go through the other party's insurer, receive 23k - 3k salvage fee and keep the car. So 20k plus the car, which will not be roadworthy anymore. Could I ask for some of your advice, especially if you faced a similar situation in the past? Is it worth keeping the car with 20k, would I be able to sell it for parts or sell it as a whole? It's in a very good condition (minus the chassis and rear damage obviously), engine has done 94k and never had any problems.   Thank you very much for your advice in advance!!!
    • Passenger Seat Sensor
      By BlueZ · Posted
      Hello all, Well it's been a few years but It's good to see this forum is still up and running.  I notice the old Speedo thread is still active :-) So, I was driving with my wife today and she noticed that the seat belt warning didn't go off when she took of the belt as we pulled into the driveway.  I assume that it's the seat sensor.  It doesn't worry me too much but I'm wondering if it will affect the air bags.  Will they go off if it thinks there's no one in the seat? Thanks